Support

Which hardware and Android version is recommended?

There are more than 10.000 devices running Android, FEER is supported on over 9000. Any Android Version from 4.1 should work, but we recommend a more recent one.

Last update on 2018-10-18 by Hansjörg.

Go back

Couldn't find an answer?

Contact Support